Boost logo

Boost-Build :

From: Vladimir Prus (ghost_at_[hidden])
Date: 2005-02-03 10:11:42

On Sunday 23 January 2005 19:06, Mal Cifuentes wrote:

> > In last, release, most tests passed with borland, suggesting that tlib
> > something works.
> I downloaded latest release of bjam, and executed the tests on a clean
> machine.
> XP, BB6, Python 2.2
> The tests failed miserably. Probably because they seem to want to run with
> g++ and not the borland tool set.
> I executed the tests as described in the readme.txt file.

For borland, you need to pass the "borland" argument:

python borland

> Executing example/libraries produced the following error (tlib fails):
> cd c:\boost-build\example\libraries
> ..\..\jam_src\bin.ntx86\bjam.exe link=static --exe
> ...found 22 targets...
> ...updating 4 targets...
> borland.archive lib1\bin\borland\debug\link-static\lib1.lib
> TLIB 4.5 Copyright (c) 1987, 1999 Inprise Corporation
> Warning: unknown command line switch 'b' ignored
> Error: unexpected char 'i' in command line
> "C:\Program Files\Borland\CBuilder6/bin/tlib" /u /a /C
> "lib1\bin\borland\debug\link-static\lib1.lib"
> +-"lib1\bin\borland\debug\link-static\lib1.obj"

Worked for me just fine. The command line was:

"W:\CBuilderX/bin/tlib" /u /a /C

(The file names are different because directory and file names were changed in

"tlib" indentifies itself with:

TLIB 4.5 Copyright (c) 1987, 1999 Inprise Corporation

I think this was part of "CBuilderX Personal" install. What's your version?

> >> It would seem that trying to pass a directory with a - (i.e.
> >> bin/Borland/debug/link-static/Blah.lib) in the library name causes a
> >> problem for tlib. This is regardless of the type of environment (cygwin
> >> or dos).
> >
> > Strange, some tests create path with "link-static" in it.
> I'm baffled. I would like to get to the bottom of this, can you show me
> the command that is executed, and its output.

Well, the above is one example. Attached is the complete output of "bjam -n
borland" -- which later worked OK without "-n".

> >> Having said that, upon further investigation in borland.jam there
> >> appears to be a work around in place. When using CYGWIN a function is
> >> defined to create a temporary batch file to execute the tlib command.
> >
> > The comment there states the problem only occurs when invoking tlib from
> > bash.
> > Is that what you're doing?
> no-I started using cygwin(zsh), then rolled back to cmd.exe when it failed.

I've used "Accessories->Command prompt" on Win 2000.

> What was interesting about

Did you forget to finish this sentence?

> >> I can think of only two solutions to this problem:
> >>
> >> 1. execute tlib from with in the lib directory (maybe this is what the
> >> batch file is trying to achieve) - currently what I am doing!
> >>
> >> 2. change the directory structure so there is no dash, which I would
> >> love to know how to do for other reasons.
> >
> > Can you explain the other reasons? Do you mean changing the dash with,
> > say,
> > '=', or something else?
> Reasons:
> 1. would pefer to use an underscore (_) - not a reason, just a gripe:)
> 2. it would be nice to be able to change the structure to reflect
> other structures that people are used to. No idea how this would be done
> in bjam without the use of partial variable instantiation:)

This would be nice indeed.

> 3. I would like to be able to add more structure (trace, code_guard),
> examples:
> bin/borland/trace
> bin/borland/code_guard
> Apoligies if this is in the doco, i havn't focused on this aspect
> of bbuild, I'm still trying to come to grips with linking:)

You can define a new feature, and it will show up in path. See

> I have provided a patch for borland.jam, log could be:
> 1. simplifies link action to one function regardless of the users
> enviornment (i.e. cygwin or nt)
> 2. removed issue where -static in library path was confusing tlib and
> causing an error
> 3. increased the library page file size to something more reasonable
> I know issue 2 above is contentious at the moment:) Issue 1 is a step in
> the right direction regardless:)
> If the patch is inadequate or poorly created please clue me in. I couldn't
> get access to the cvs repository so i patched against a nightly build
> version.

This patch looks OK and I'm about to apply this after I test on cygwin.
Figuring out why nothing fails in my case is still desirable.

- Volodya
 --Boundary-00=_u8jAC/nbd8D+3U3 Content-Type: text/plain;
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment;

warning: toolset fop initialization:
warning: can't find user-provided command '/home/ghost/build/fop/'
warning: initialized from
...found 23 targets...
...updating 6 targets...
borland.compile.c++ app\bin\borland-5.6.4\debug\link-static\app.obj

W:\CBuilderX\bin\bcc32.exe -j5 -g255 -q -c -P -w -Ve -Vx -a8 -b- -v -Od -tWC -tWR -tWC -WM- -I"util\foo\include" -I"W:\CBuilderX/include/" -o"app\bin\borland-5.6.4\debug\link-static\app.obj" "app\app.cpp"

borland.compile.c++ util\foo\bin\borland-5.6.4\debug\link-static\bar.obj

W:\CBuilderX\bin\bcc32.exe -j5 -g255 -q -c -P -w -Ve -Vx -a8 -b- -v -Od -tWC -tWR -tWC -WM- -I"W:\CBuilderX/include/" -o"util\foo\bin\borland-5.6.4\debug\link-static\bar.obj" "util\foo\bar.cpp"

borland.archive util\foo\bin\borland-5.6.4\debug\link-static\bar.lib

"W:\CBuilderX/bin/tlib" /u /a /C "util\foo\bin\borland-5.6.4\debug\link-static\bar.lib" +-"util\foo\bin\borland-5.6.4\debug\link-static\bar.obj"

response-file-1 app\bin\borland-5.6.4\debug\link-static\app.rsp

echo "app\bin\borland-5.6.4\debug\link-static\app.obj" > "app\bin\borland-5.6.4\debug\link-static\app.rsp"

response-file-2 app\bin\borland-5.6.4\debug\link-static\app.rsp

echo "util\foo\bin\borland-5.6.4\debug\link-static\bar.lib" >> "app\bin\borland-5.6.4\debug\link-static\app.rsp"

text-action app\bin\borland-5.6.4\debug\link-static\app.rsp

echo. >> "app\bin\borland-5.6.4\debug\link-static\app.rsp" app\bin\borland-5.6.4\debug\link-static\app.exe app\bin\borland-5.6.4\debug\link-static\app.rsp

set "PATH=W:\CBuilderX/bin/;%PATH%"
W:\CBuilderX\bin\bcc32.exe -v -q -v -v -tWC -tWR -tWC -WM- -L"W:\CBuilderX/lib" -e"app\bin\borland-5.6.4\debug\link-static\app.exe" @"app\bin\borland-5.6.4\debug\link-static\app.rsp"

...updated 6 targets...

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at