Boost logo

Boost-Build :

From: Jim Douglas (jim_at_[hidden])
Date: 2006-02-22 06:26:20

Vladimir Prus wrote:

Just to complete the picture my user-config.jam contains:

using qcc : 3.3.5_cpp : : <compileflags>-V3.3.5,gcc_ntox86_cpp
<linkflags>-V3.3.5,gcc_ntox86_cpp ;

using qcc : 3.3.5_gpp : : <compileflags>-V3.3.5,gcc_ntox86_gpp
<linkflags>-V3.3.5,gcc_ntox86_gpp ;

> If you send me the output of, I'll take a look.
Attached as test_all_*.txt.bz2. I did a run with each toolset in case
there are differences.

>>I have also started a run of the regression tests but I stopped when I
>>saw that there is a problem with I need to add 'libm' to each
>>of the linking rules because it has been omitted from the default search
>>list on this platform. I have tried adding this as FINDLIBS and
>>FINDLIBS-SA but it does not always show up in the right places.
> When I run "bjam -n qcc" on the hello example, I get this:
> bin/qcc/debug/main
> QCC -o "bin/qcc/debug/main" "bin/qcc/debug/main.o" "bin/qcc/debug/a.o"
> -lm -gstabs+
> That is, the "-lm" is there. Is that right? Do you get "-lm" when building
> "hello"? And "libraries"?

In this context it is correct.

When I run the regression test from I get the following
failure of "math_info" with the commands:

     "QCC" -o
    -gstabs+ -V3.3.5,gcc_ntox86_cpp

But then if I cd to lib/config/test and run "bjam --v2 qcc-3.3.5_cpp
math_info" I get a pass with these commands:

     "QCC" -o
   -lm -gstabs+ -V3.3.5,gcc_ntox86_cpp

Ah! I can see now that it has something to do with threading, but then
all qcc stuff should default to multithreading and there is no switch as
with gcc. AFAIK qcc always inserts the "-pthread" option automatically
for gcc.

What's going on here?


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at