Boost logo

Boost-Build :

Subject: Re: [Boost-build] Confused with
From: Dmitry Timoshenko (dimentiy2k_at_[hidden])
Date: 2011-04-08 08:24:59


I build my library using boost build.

The problem is that I can only compile it with 3.1.18 &
boost 1.41.

When I use > 3.1.18 I get an error. Please see recent post
named 'Issue with boost build'.

I also tried to use boost build that comes with boost 1.45
( 3.1.19) I get the same error as when I use nightly build.

D:/work/extra/boost-build\build-system.jam:722: in load
*** argument error
* rule project.load ( jamfile-location )
* called with: ( )
* missing argument jamfile-location
D:/work/extra/boost-build/build\project.jam:53:see definition of rule
'load' being called
D:\work\extra\boost-build\kernel\modules.jam:283: in import
D:\work\extra\boost-build\kernel\bootstrap.jam:142: in boost-build
D:\work\extra\boost-build\boost-build.jam:8: in module scope

But this 3.1.19 succesfully builds boost 1.45. But when I
use it with my scripts the error occurs. The error happens in scripts: D:/work/extra/boost-build\build-system.jam:722.

I repeat that my scripts working properly with boost 1.41 &

When I use > 3.1.18 it causes an error and the version of
boost doesn't matter. It can be either 1.41 or 1.45 error happens anyway.

Scripts available here:

Thank you.

> On 4/7/2011 8:34 PM, Dmitry Timoshenko wrote:
>> Hello,
>> I compile my library with
>> I use 3.1.18
>> (
>> It works fine but only with boost 1.41. If I try to use it with boost
>> 1.45 I got an error.
> There is no need to download from sourceforge. It is
> included in the boost distribution in:
> boost/tools/build
> As for building boost, you should be using boost/booststrap.bat on
> windows. See the Getting Started instructions for details:
> <>
> michael

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at