Boost logo

Boost-Build :

Subject: Re: [Boost-build] path-constant in Jamroot does not work in subdirs
From: Jurko Gospodnetić (jurko.gospodnetic_at_[hidden])
Date: 2012-06-27 19:23:40


>> Could you give a minimal project reproducing this behaviour? I tried
>> reproducing it here and everything I tried seems to work fine.
> Sorry for the late reply. Attached you will find a minimal project. It
> does not compile, but that is not the point... This is the directory
> structure:
> bjam-problem
> └── cgi
> ├── appl
> └── base

   Don't mean to mess with you, but I still can not reproduce the
problem with the current trunk version.

   Note though that your project is not self-contained and it depends on
targets defined in your site-config.jam file. Could you try to reduce it
so it does not?

   Also, see if your bug occurs when using the -n option. If it does
then that can be used to eliminate anything specific to the exernal
tools run by the build system on your site.

   I tried the following:
     * Commented out all /site-config//... lines in appl & base projects
to eliminate warnings about there being no site-config project.
     * Ran bjam -n -d1 from the base bjam-problem folder - worked fine.
     * Ran bjam -n -d1 from the bjam-problem/cgi folder - worked fine.
     * Ran bjam -n -d1 from the bjam-problem/cgi/appl folder - worked fine.
     * Ran bjam -n -d1 from the bjam-problem/cgi/base folder - worked fine.

   Without the -n option the builds get to the action running stage and
then fail somewhere down the line but the reason for that does not seem
to be related to your problem.

   Hope this helps.

   Best regards,
     Jurko Gospodnetić

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at