Boost logo

Boost-Build :

Subject: Re: [Boost-build] path-constant in Jamroot does not work in subdirs
From: Andrej van der Zee (andrejvanderzee_at_[hidden])
Date: 2012-06-27 20:58:24

Cau Jurko,

Thanks for your reply.

>  Don't mean to mess with you, but I still can not reproduce the problem with
> the current trunk version.
>  Note though that your project is not self-contained and it depends on
> targets defined in your site-config.jam file. Could you try to reduce it so
> it does not?

Yes it is not self-contained, I am sorry about that. I spend some time
making it a small self-contained project, but then the bjam-problem
goes away mistereously...

>  I tried the following:
>    * Commented out all /site-config//... lines in appl & base projects to
> eliminate warnings about there being no site-config project.
>    * Ran bjam -n -d1 from the base bjam-problem folder - worked fine.
>    * Ran bjam -n -d1 from the bjam-problem/cgi folder - worked fine.
>    * Ran bjam -n -d1 from the bjam-problem/cgi/appl folder - worked fine.
>    * Ran bjam -n -d1 from the bjam-problem/cgi/base folder - worked fine.

Hmmmm that is strange. I have problems with the INSTALL_PATH variable
defined in Jamroot. In Jamfiles I use this in install command like

install $(INSTALL_PATH)/htbin : nph-mbrace.cgi ;

But this gives me the following errors (this error does *not* occur
when I run bjam from the project root):

andrej_at_amd64:~/mbrace/trunk/cgi$ bjam
../cgi/base/Jamfile:20: in modules.load
*** argument error
* rule install ( name : sources * : requirements * : default-build * )
* called with: ( : cgi_base )
* missing argument name
/usr/share/boost-build/tools/stage.jam:499:see definition of rule
'install' being called
/usr/share/boost-build/build/project.jam:314: in load-jamfile
/usr/share/boost-build/build/project.jam:62: in project.load
/usr/share/boost-build/build/project.jam:766: in project.use
/usr/share/boost-build/build/project.jam:89: in load-used-projects
/usr/share/boost-build/build/project.jam:73: in load
/usr/share/boost-build/build/project.jam:115: in load-parent
/usr/share/boost-build/build/project.jam:464: in initialize
/usr/share/boost-build/build/project.jam:309: in load-jamfile
/usr/share/boost-build/build/project.jam:62: in load
/usr/share/boost-build/build/project.jam:168: in project.find
/usr/share/boost-build/build-system.jam:570: in load
/usr/share/boost-build/kernel/modules.jam:283: in import
/usr/share/boost-build/kernel/bootstrap.jam:142: in boost-build
/usr/share/boost-build/boost-build.jam:8: in module scope

When I replace INSTALL_PATH in the install command like this:

install /root/htbin : nph-mbrace.cgi ;

Then it works perfectly fine...



Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at