Boost logo

Boost-Build :

Subject: Re: [Boost-build] boost library compile error on Linux 3.2.2-5
From: Vladimir Prus (ghost_at_[hidden])
Date: 2012-11-30 01:24:19

On 30.11.2012 01:23, Lynn Johnson wrote:
> We have a large Windows application that I am trying to port to Linux. Our group has decided to check out Boost the boost libraries for
> this port. I have downloaded and expanded the Boost .tar file (boost_1_52_0) and am following the instructions listed on the Boost “Getting
> Started on Unix variants” page. My OS is a virtual machine running Red hat Linux 3.2.2-5. This is the linux version our customer has.
> I have successfully executed ./ to set up prefixes and specified “—with-libraries” for the thread library. When I run “./b2
> install” all compiles are failing with the error “cclplus: unrecognized option ‘-Wextra’ “
> I would like to try compiling with this option set to “-W” instead of –Wextra but I have been unable to find the Boost file that lists the
> compiler options. I’ve googled and seen mention of a boost/status/compiler.cfg file but that file does not exist in the boost/status
> directory that was unpacked today. I tried running a “find” command from the boost_1_52_0 directory and came up empty.
> Can someone tell me where the compiler options are declared so I can alter them? Any suggestions you have are greatly appreciated.

Hi Lynn,

the compiler options are set in tools/build/v2/tools/gcc.jam - but, I don't see -Wextra there. It appears that the thread library
adds it here:


if you remove the line that say:


that option will not be passed to the compiler.

Note that I am not quite sure which Linux you have. If 3.2.2-5 refers to your kernel version, then it is of very little interest when
building Boost.


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at