Boost logo

Boost-Build :

Subject: [Boost-build] boost library compile error on Linux 3.2.2-5
From: Lynn Johnson (johnsonl_at_[hidden])
Date: 2012-11-29 16:23:38

We have a large Windows application that I am trying to port to Linux. Our group has decided to check out Boost the boost libraries for this port. I have downloaded and expanded the Boost .tar file (boost_1_52_0) and am following the instructions listed on the Boost "Getting Started on Unix variants" page. My OS is a virtual machine running Red hat Linux 3.2.2-5. This is the linux version our customer has.

I have successfully executed ./ to set up prefixes and specified "-with-libraries" for the thread library. When I run "./b2 install" all compiles are failing with the error "cclplus: unrecognized option '-Wextra' "

I would like to try compiling with this option set to "-W" instead of -Wextra but I have been unable to find the Boost file that lists the compiler options. I've googled and seen mention of a boost/status/compiler.cfg file but that file does not exist in the boost/status directory that was unpacked today. I tried running a "find" command from the boost_1_52_0 directory and came up empty.

Can someone tell me where the compiler options are declared so I can alter them? Any suggestions you have are greatly appreciated.

Thanks - Lynn

This e-mail message and any attachments are confidential
and proprietary to Advion Inc., subject to copyright, and intended only for the use of the named recipient(s). If you are not an intended recipient, you have received this message in error and any review, copying, disclosure, distribution or other use or exploitation of it or its contents is strictly prohibited. If you have received this message in error, please immediately notify the sender and permanently destroy all copies of it.

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at