Boost logo

Boost-Build :

Subject: [Boost-build] Default toolset not detected during run of b2
From: Michael Price (michael.price_at_[hidden])
Date: 2013-10-07 14:35:55

On AIX using IBM XL C/C++ (vacpp).

When I run, it correctly detects that the toolset is vacpp,
but when I run the resulting b2 binary, it complains that no toolsets are

warning: No toolsets are configured.
warning: Configuring default toolset "gcc".
warning: If the default is wrong, your build may not work correctly.
warning: Use the "toolset=xxxxx" option to override our guess.
warning: For more configuration options, please consult

Could this be because I have the toolset installed in a non-default
location (if you read my previous email about Solaris, the toolset
detection during configure works here because it just tests that 'xlc' is
on the path for vacpp, whereas on sun it looks in a specific path).

*Michael Price*
Senior Software Engineer - Infrastructure
Perceptive Software | from Lexmark

NOTICE: If received in error, please destroy the message and notify sender.
Sender does not waive confidentiality or privilege, and use is prohibited.

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at