Boost logo

Boost-Build :

Subject: Re: [Boost-build] Default toolset not detected during run of b2
From: Vladimir Prus (ghost_at_[hidden])
Date: 2013-10-07 15:19:08

On 07.10.2013 22:35, Michael Price wrote:
> On AIX using IBM XL C/C++ (vacpp).
> When I run, it correctly detects that the toolset is vacpp, but when I run the resulting b2 binary, it complains that no
> toolsets are configured.
> warning: No toolsets are configured.
> warning: Configuring default toolset "gcc".
> warning: If the default is wrong, your build may not work correctly.
> warning: Use the "toolset=xxxxx" option to override our guess.
> warning: For more configuration options, please consult
> warning:
> Could this be because I have the toolset installed in a non-default location (if you read my previous email about Solaris, the toolset
> detection during configure works here because it just tests that 'xlc' is on the path for vacpp, whereas on sun it looks in a specific path).

Unless user-config.jam (or project-config.jam) has explicit

        using vacpp ;

b2 will not try to configure that toolset. Generally, if no toolset is specified, we try gcc on Unixy hosts and msvs on Windows.

- Volodya

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at