Boost logo

Boost-Build :

Subject: Re: [Boost-build] Default toolset not detected during run of b2
From: Michael Price (michael.price_at_[hidden])
Date: 2013-10-07 15:29:12

So, if I understand correctly, specifying --with-toolset during the
bootstrap only specifies the tool to use to create the bjam/b2 binary, not
what toolset that binary uses during execution?

*Michael Price*
Senior Software Engineer - Infrastructure
Perceptive Software | from Lexmark

(O) +1 913 667 6137

NOTICE: If received in error, please destroy the message and notify sender.
Sender does not waive confidentiality or privilege, and use is prohibited.

On Mon, Oct 7, 2013 at 2:19 PM, Vladimir Prus <ghost_at_[hidden]> wrote:

> On 07.10.2013 22:35, Michael Price wrote:
>> On AIX using IBM XL C/C++ (vacpp).
>> When I run, it correctly detects that the toolset is vacpp,
>> but when I run the resulting b2 binary, it complains that no
>> toolsets are configured.
>> warning: No toolsets are configured.
>> warning: Configuring default toolset "gcc".
>> warning: If the default is wrong, your build may not work correctly.
>> warning: Use the "toolset=xxxxx" option to override our guess.
>> warning: For more configuration options, please consult
>> warning:**doc/html/bbv2/advanced/**
>> configuration.html<>
>> Could this be because I have the toolset installed in a non-default
>> location (if you read my previous email about Solaris, the toolset
>> detection during configure works here because it just tests that 'xlc' is
>> on the path for vacpp, whereas on sun it looks in a specific path).
> Unless user-config.jam (or project-config.jam) has explicit
> using vacpp ;
> b2 will not try to configure that toolset. Generally, if no toolset is
> specified, we try gcc on Unixy hosts and msvs on Windows.
> - Volodya

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at