Boost logo

Boost-Build :

Subject: Re: [Boost-build] Changed behaviour of custom generators?
From: Roland Schwarz (roland.schwarz_at_[hidden])
Date: 2014-04-22 02:18:42

Nn 03.04.2014 17:02, Steven Watanabe wrote:
> On 04/03/2014 05:19 AM, Roland Schwarz wrote:
>> On 02.04.2014 17:10, Steven Watanabe wrote:
>>> Can you try running with -d+4 which should print
>>> out the string passed to CreateProcessA.
>> Ok, several things happened:
>> 1)
>> The log entry changed to "Command string for CreateProcessA():
>> '-ftemplate-depth-128 ..."
>> which I know from earlier experience as indicating an inability of
>> boost-build to detect my compiler.
> I suppose this is a b2 bug. It shouldn't
> stop dead when an updating action fails.
Ok, I was using the wrong version. I used the last SVN version. Now I
caught up to modular-boost on git but the problem persist.

What is interesting is that when I run with --debug-configuration I can
clearly see:
notice: will use 'C:/subsys/win32/mingw-4.6.2/bin/g++.exe' for gcc,
condition <toolset>gcc-4.6.2-mingw32
notice: using gcc libraries :: <toolset>gcc-4.6.2-mingw32 ::
C:/subsys/win32/mingw-4.6.2//bin C:/subsys/win32/mingw-4.6.2//lib
C:/subsys/win32/mingw-4.6.2//lib32 C:/subsys/win32/mingw-4.6.2//lib64
notice: using gcc archiver :: <toolset>gcc-4.6.2-mingw32 ::
notice: using gcc ranlib :: <toolset>gcc-4.6.2-mingw32 ::

I interpret this as the b2 was able to find the compiler, but when I
specify it as a requirement on the command line, nothing happens, i.e. I
can see the earlier message in the log file of '-ftemplate ....'

What else could I check? (Remember this worked before upgrade without


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at