Boost logo

Boost-Build :

Subject: [Boost-build] custom bcp build no longer finds boost-build.jam in 1.57.0
From: Kevin Moody (kevine.moody_at_[hidden])
Date: 2014-12-01 14:07:35

I have been using a custom namespace for my boost libraries, as well as
only building a small subset of modules. Therefore, I follow this process
(which worked fine in 1.53 and 1.55):

1. build b2, via bootstrap
2. build bcp, via b2
3. use bcp to copy modules (including build) to a new directory
4. update the includes, using a script
5. build the copied modules, using b2 from the original boost src directory
(built in step 1)

However, step 5 now fails to find boost-build.jam in the latest version,
boost 1.57.0. I tried to look over similar topics on the mailing list, but
they don't seem to have a suitable solution for my case. Also, I tried

-sBOOST_ROOT=<new directory>

and the BOOST_ROOT environment variable, but got the same error message.

Did I miss some breaking behavior, where this process will no longer work?
Any suggestions are greatly appreciated.

Note: I did update the location of b2, due to the change from
tools/build/v2 to tools/build/src. That was the only change required to
get me to step 5.


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at