Boost logo

Boost-Build :

Subject: Re: [Boost-build] custom bcp build no longer finds boost-build.jam in 1.57.0
From: Vladimir Prus (vladimir.prus_at_[hidden])
Date: 2014-12-02 02:46:12

On 12/01/2014 10:07 PM, Kevin Moody wrote:
> I have been using a custom namespace for my boost libraries, as well as only building a small subset of modules. Therefore, I follow this
> process (which worked fine in 1.53 and 1.55):
> 1. build b2, via bootstrap
> 2. build bcp, via b2
> 3. use bcp to copy modules (including build) to a new directory
> 4. update the includes, using a script
> 5. build the copied modules, using b2 from the original boost src directory (built in step 1)
> However, step 5 now fails to find boost-build.jam in the latest version, boost 1.57.0. I tried to look over similar topics on the mailing
> list, but they don't seem to have a suitable solution for my case. Also, I tried using:
> -sBOOST_ROOT=<new directory>
> and the BOOST_ROOT environment variable, but got the same error message.

Hi Kevin,

what's the error message exactly? Would the following work:

        <original-src>/b2 -sBOOST_BUILD_PATH=<original-src>/tools/build [further options]


Vladimir Prus

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at