Boost logo

Boost-Build :

Subject: Re: [Boost-build] Issue building boost from root directory
From: celijahh (celijahh_at_[hidden])
Date: 2016-07-07 16:15:07

It seems you are right.  I re-ran bootstrap.bat but this time from the root and then ran the b2 install command again and it seems to be building now.  For some reason,  it's been running for around 30 minutes. How long is it supposed to take?

Sent from my Verizon, Samsung Galaxy smartphone
-------- Original message --------From: Vladimir Prus <vladimir.prus_at_[hidden]> Date: 7/7/16 2:41 PM (GMT-05:00) To: boost-build_at_[hidden] Subject: Re: [Boost-build] Issue building boost from root directory
On 07-Jul-16 8:01 PM, celijahh wrote:
> Hi,
> I've been trying to build the Apache qpid messaging broker which
> requires boost. I set the variable BOOST_ROOT to the path of the boost
> root directory,  but it could only find some of the libraries.  I was
> informed that some of the other libraries needed to be compiled so I
> went through the documentation in section 5.2 for installing on windows.
>  I ran bootstrap.bat and then tried to run the b2 install command from
> the root but got the message that b2 wasn't recognized. So I went to
> tools\build and ran it there which worked.  However when I ran the
> command from 5.2.4 for the build directory I get the message that it
> doesn't know how to find the target or how to make <e>stage. Now boost
> is located in downloads on my machine so maybe that could have something
> to do with it,  but does anyone know what could be going wrong?


I have to suggestions:

- If you have "b2" built correctly, copy it to the root of your Boost
tree, and run the command from 5.2.4 there. It's not supposed to be
run from "tools/build"

- If you ran bootstrap.bat from root folder and it failed to produce b2
   binary, it should have produced some error messages. Could you post


Unsubscribe & other changes:

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at