Re: [Boost-docs] function.xml vs boostbook.dtd

Subject: Re: [Boost-docs] function.xml vs boostbook.dtd
From: Daniel James (daniel_james_at_[hidden])
Date: 2008-07-20 19:07:34

2008/7/19 Adder <adder.thief_at_[hidden]>:
> It seems that the attribute xmlns:xi=""
> on the "library" element is not supported by boostbook.dtd.
> All the files that use <xi:include href="..."> generate errors when
> processed with xsltproc ("Using libxml 20632, libxslt 10123 and
> libexslt 813").

It seems that most boostbook documents aren't valid according the the
dtd, which isn't a good situation but doesn't generally cause
problems. Xsltproc normally only requires well formed documents.

> The MSXML parser signals the same error (function.xml, line 6).
> I would like to ask someone who is more experienced with BoostBook to
> take 5 minutes of his/her time and test the instructions posted here
> on Windows (only up to building function.xml, even without downloading
> local copies of the DTD/XSD files.
> They don't seem to work... unless skipping validation against the
> boostbook.dtd file (e.g. by erasing the file).

I'm afraid I'm not much help, as I don't use windows. You might find
the quickbook installation instructions helpful:

You mentioned in your earlier email that you tried the metacomm
xsltproc and then the Igor Zlatkovic's version. According to the
archives, the metacomm one doesn't work (I'll look into removing the
link) and it could be that when using the Zlatkovic xsltproc you were
still using one of the dlls from metacomm. If you haven't already, you
could try deleting all the files from metacomm, and installing the
packages from Zlatkovic that are mentioned in the quickbook
documentation (iconv, zlib, libxml2 and libxslt).

Also, you mentioned changing the boostbook setup in user-config.jam.
It's possible that when you did this 'catalog.xml' wasn't updated. If
you run 'bjam -a' is should force that, or you could delete it (it's
in 'bin.v2'). I think that was fixed in the build system, but I'm not
sure so that might cause a problem.

Sorry if you've tried these things. A few people do use boostbook on
windows, but I guess they're not reading this list at the moment. Or
maybe they use cygwin.

If you're still stuck, you could try runnig 'bjam -na' to see exactly
what commands are run. If there is a configuration problem, it might
show up in the output.


This archive was generated by hypermail 2.1.7 : 2017-11-11 08:50:40 UTC