Re: [Boost-docs] function.xml vs boostbook.dtd

Subject: Re: [Boost-docs] function.xml vs boostbook.dtd
From: Adder (adder.thief_at_[hidden])
Date: 2008-07-22 15:05:49

Sunday, July 20, 2008, 10:07:34 PM, Daniel James wrote:

DJ> 2008/7/19 Adder <adder.thief_at_[hidden]>:
>> It seems that the attribute xmlns:xi=""
>> on the "library" element is not supported by boostbook.dtd.
>> All the files that use <xi:include href="..."> generate errors when
>> processed with xsltproc ("Using libxml 20632, libxslt 10123 and
>> libexslt 813").

DJ> It seems that most boostbook documents aren't valid according the the
DJ> dtd, which isn't a good situation but doesn't generally cause
DJ> problems. Xsltproc normally only requires well formed documents.

After un-commenting lines 27-36 of boostbook.dtd, xsltproc
successfully processes files that contain xi:include !

We still get the error:

  function.xml:6: namespace error : Namespace prefix xmlns for xi on library is not defined

but xsltproc can proceed, despite this message. Could it be that the
element "library" does not support the "xmlns:xi" attribute ?

>> The MSXML parser signals the same error (function.xml, line 6).
>> I would like to ask someone who is more experienced with BoostBook to
>> take 5 minutes of his/her time and test the instructions posted here
>> on Windows (only up to building function.xml, even without downloading
>> local copies of the DTD/XSD files.
>> They don't seem to work... unless skipping validation against the
>> boostbook.dtd file (e.g. by erasing the file).

DJ> I'm afraid I'm not much help, as I don't use windows. You might find
DJ> the quickbook installation instructions helpful:


Thank you. I had already came upon it.

DJ> You mentioned in your earlier email that you tried the metacomm

Sorry for having "spammed" the list a little bit. :(

DJ> xsltproc and then the Igor Zlatkovic's version. According to the
DJ> archives, the metacomm one doesn't work (I'll look into removing the
DJ> link) and it could be that when using the Zlatkovic xsltproc you were
DJ> still using one of the dlls from metacomm. If you haven't already, you
DJ> could try deleting all the files from metacomm, and installing the
DJ> packages from Zlatkovic that are mentioned in the quickbook
DJ> documentation (iconv, zlib, libxml2 and libxslt).

I have unpacked the two xsltproc versions in separate folders; none of
them is in the PATH. I have xsltproc.bat in the path, redirecting to
the xsltproc.exe of my choice, which loads the .dll's from its own

DJ> Also, you mentioned changing the boostbook setup in user-config.jam.
DJ> It's possible that when you did this 'catalog.xml' wasn't updated. If
DJ> you run 'bjam -a' is should force that, or you could delete it (it's
DJ> in 'bin.v2'). I think that was fixed in the build system, but I'm not
DJ> sure so that might cause a problem.

I had also verified that boostbook_catalog.xml is generated correctly,
with references to the paths of my local copies of DocBook-related files.

DJ> Sorry if you've tried these things. A few people do use boostbook on
DJ> windows, but I guess they're not reading this list at the moment. Or
DJ> maybe they use cygwin.

DJ> If you're still stuck, you could try runnig 'bjam -na' to see exactly
DJ> what commands are run. If there is a configuration problem, it might
DJ> show up in the output.

Thank you for all your help !

This archive was generated by hypermail 2.1.7 : 2017-11-11 08:50:40 UTC