Boost logo

Boost :

From: Mateusz Loskot (mateusz_at_[hidden])
Date: 2019-07-12 17:30:56

Hi All,

Naming things is hard [1].

While adding the gil/image_processing directory to our Doxygen config,
I've realised the current name may not necessarily be the best name.

For example, there are directories
- gil/image for implementation of the image class.
- gil/image_view for implementation of the image_view class

In most cases features in gil/image_processing will operate on instances
of image_view, but there may also be tools operating on more generic data
like raw arrays of numeric values or pixels and pixel elements.
So, scope indicating by the image_processing name may become too narrow.

Alternative name that I have been considering is just gil/processing.

What is others opinion?
Any suggestions for a good or better name?


Best regards,

Mateusz Loskot,

Boost list run by Boost-Gil-Owners