Boost logo

Boost Testing :

From: Robert Ramey (ramey_at_[hidden])
Date: 2005-10-02 11:55:08

I did spend some time a while ago with this. tried to discover where in the
test library borland was having trouble with. Since this only occurred in
release mode it was problematic. Now I'm thinking that the best avenue
might be just to tweak the Jamfiles for Boost Test and or Boost
Serialization to turn off the optimizations for borland when building the
test library. This would permit me to run the rest (ie my own code) in
release mode with full optimization - which is what I want to do. That is I
suspect we can just work around the problem well enough to move on. I
haven't tried this and am leaving for a trip so I won' t have time to.

There is another issue regarding the Boost Test, Boost Serialization, and
the Comeau compiler. When I try link the serialization library and the test
library into the same executable, I get duplicate symbol from the (VC
backend) linker. I fiddled a bit with the Jamfile to try to set a link
command line switch but was unsuccessful. I'm still considering this. I
would like to the serialization library pass on the Comeau compiler as a
double check on code quality but I can't do that now.

Robert Ramey

Gennadiy Rozental wrote:
>> I've been running tests on my local machine in release mode. It
>> turns out that all my tests fail with the message
>> Run output:
>> EXIT STATUS: -1073741819
>> This occurs with both borland 5.51 and 5.64 compilers.
>> I think i recall having this before and concluding
>> that it was an issue with Boost Test
>> Perhaps someone might have a look at this.
> I will try. But I couldn't promise immediate success.
> Gennadiy

Boost-testing list run by mbergal at