Boost logo

Boost Testing :

From: Andreas Huber (ahd6974-spamgroupstrap_at_[hidden])
Date: 2006-03-14 16:45:03

Hi Volodya

> can you switch C++ Boost regression tests that you're running to
> Boost.Build V2?

Sure, I tried but failed, see below.

> If you have any issues or concerns or questions, please ask me right
> away, either here, or via personal email, or via Jabber
> (vladimir_prus_at_[hidden]), or via ICQ (100422315), or via Skype
> (vladimir_prus).

I tried with the following .bat file:

cd D:\BoostRegression\MyDocuments
set BOOST_BUILD_PATH=D:\BoostRegression\MyDocuments
rmdir /s /q .\boost\status
"C:\ProgramFiles\Python23\python" --v2 --toolsets=msvc-7.1 --runner=huber-V2 --bjam-options="-l600"
1>>result.txt 2>&1

and with the file user-config.jam located in

import toolset : using ;
using msvc : 7.1 : "C:\Program Files\Microsoft Visual Studio .NET
2003\Vc7\bin\cl" ;
using python : 2.3 : C:\ProgramFiles\Python23 ;

After a while, I get the following error:

 --v2 "-sBOOST_BUILD_PATH=D:\BoostRegression\MyDocuments"
"-sBOOST_ROOT=D:\BoostRegression\MyDocuments\boost" msvc-7.1
warning: Python location is not configured
warning: the Boost.Python library won't be built
Building Boost.Regex with the optional Unicode/ICU support disabled.
Please refer to the Boost.Regex documentation for more information
(and if you don't know what ICU is then you probably don't need it).
warning: no toolsets are configured.
warning: you won't be able to build C++ programs.
warning: please consult the documentation.

notice: could not find main target msvc-7.1
notice: assuming it's a name of file to create
error: unable to construct
To debug this problem, try the --debug-generators option.

# Searching for "process_jam_log.exe" in
Traceback (most recent call last):
  File "", line 927, in ?
    commands[ command ]( **accept_args( args ) )
  File "", line 748, in regression
    v2, [] )
  File "", line 460, in setup
    build_if_needed( process_jam_log, pjl_toolset, toolsets, v2 )
  File "", line 409, in build_if_needed
    tool[ 'build_path' ] = tool_path( tool, v2 )
  File "", line 370, in tool_path
    raise Exception( 'Cannot find "%s" in any of the following
locations:\n%s' % (
Exception: Cannot find "process_jam_log.exe" in any of the following

I must be missing something...


Andreas Huber
When replying by private email, please remove the words spam and trap
from the address shown in the header.

Boost-testing list run by mbergal at