Boost logo

Boost Testing :

Subject: Re: [Boost-testing] trunk tests failing
From: Vladimir Prus (vladimir_at_[hidden])
Date: 2009-08-10 13:15:22

K. Noel Belcourt wrote:

> Hi Volodya,
> On Aug 10, 2009, at 4:22 AM, Vladimir Prus wrote:
>> Belcourt, Kenneth wrote:
>>> It seems like these files are missing references to run_mpi.
>>> ./regression/xsl_reports/test/ types =
>>> [ "compile", "compile_fail", "link", "link_fail", "run", "run_fail",
>>> "run_pyd" ]
>>> ./regression/xsl_reports/xsl/v2/
>>> add_expected_results.xsl: <xsl:when test="$type='run'
>>> or $type='run_fail' or $type='run_pyd'">
>>> ./regression/xsl_reports/xsl/v2/result_page.xsl: <xsl:when
>>> test="$test_type='run_fail'"> <xsl:text>rf</xsl:text> </xsl:when>
>>> ./regression/xsl_reports/xsl/result_page.xsl: <xsl:when
>>> test="$test_type='run_fail'"> <xsl:text>rf</xsl:text> </xsl:when>
>>> ./regression/xsl_reports/test_results.xsd: <xs:enumeration
>>> value="run_fail"/>
>>> Because I don't update the Boost installation in the test reporting
>>> directory, if someone fixes this problem, please let me know so I can
>>> update. Trunk testing will remain broken until we revert or fix this
>>> issue, sorry.
>> I have fixed this issue, on trunk, after testing that result
>> generation
>> locally appears to work right.
> Okay, I too fixed it last evening in the project where I run the
> reporting. It seemed to be working fine, though I didn't commit the
> changes to the repository. I do notice, however, that this morning
> many of the trunk testers have been deleted? Was that you or is
> there something wrong with the reporting?
> Here's all that remain.
> Writing runner document Huang-Vista-x64-intel
> Writing runner document Huang-Vista-x64
> Writing runner document Huang-Vista-x86_32
> Writing runner document Huang-Vista-x86_32_intel
> Writing runner document IBM_Canada_Ltd
> Writing runner document RWVC10
> Writing runner document RW_Mingw
> Writing runner document RW_WinXP_VC
> Writing runner document Sandia-gcc-64
> Writing runner document Sandia-intel-10.0
> Writing runner document Sandia-leopard-x86
> Writing runner document Sandia-pathscale
> Writing runner document Sandia-tiger-x86

I did not delete any test results. Debian-Sid test results appear
to be available on the ftp server, too, and are fetched by the
processing script. Can you let me know the complete command you
use to process the results and upload them?

- Volodya

Boost-testing list run by mbergal at