Boost logo

Boost Testing :

Subject: Re: [Boost-testing] Test results processing transition..
From: Tom Kent (lists_at_[hidden])
Date: 2015-01-08 08:07:11

I had my machine go down last week, and I'm only now getting back to this.
I just tried a couple runs and had two issues:

1) It takes a *long* time to run >30min....I think the previous version was
<5min on the same machine. Did it use to be an incremental process? Most of
results don't change between runs, so does it need to re-process
everything? Can it just check timestamp (or maybe checksum) of the result

2) When I completed uploading, the results page then gave a "Error
extracting file: The specified zipfile was not found." instead of showing
the matrix. Do we know what causes this? Is it possibly because two people
were uploading at the same time? Could we have the script place a small
lock file into the upload directory that the script could check for before
attempting an upload, then delete when completing (or have it time out if a
upload fails)?


On Sat, Jan 3, 2015 at 7:26 AM, Tom Kent <lists_at_[hidden]> wrote:

> On Tue, Dec 30, 2014 at 10:07 AM, Rene Rivera <grafikrobot_at_[hidden]>
> wrote:
>> On Mon, Dec 29, 2014 at 4:49 PM, Tom Kent <lists_at_[hidden]> wrote:
>>> On Mon, Dec 29, 2014 at 3:22 PM, Rene Rivera <grafikrobot_at_[hidden]>
>>> wrote:
>>>> And there wasn't a build error some place in the log?
>>> The boost-reports.log file is identical, and there isn't anything that
>>> strikes me as suspicious earlier on in the file.
>>> The full contents are here:
>>> There are also boost-reports/master.log and boost-reports/develop.log,
>>> they are both short:
>>> time: cannot run build_results: No such file or directory
>>> Command exited with non-zero status 127
>> That make me think that you aren't running the new script. Are you shure
>> you are doing something like this:
>> % cd <some-dir>
>> % mkdir testing
>> % wget
>> % chmod +x
>> % ./
>> ???
>> I tried exactly the above and it works for me. Obviously the mkdir would
>> only be done the first time.
> This is exactly what I had done...I tried it again with a fresh download
> of the script, same problem.
> Then I went and removed the two time commands before the sh function calls
> (lines 13&14) and it all ran correctly. I'm not sure why my time doesn't
> handle those functions (Ubuntu 12.04), but I'm not a sh script expert so I
> could be missing something crucial.
> Tom

Boost-testing list run by mbergal at