Boost logo

Boost Users :

From: Rich Johnson (rjohnson_at_[hidden])
Date: 2004-01-15 15:51:41

On Thursday, January 15, 2004, at 09:40 AM, Jim.Hyslop wrote:

> Angus Leeming [mailto:angus.leeming_at_[hidden]] wrote:
>> Jeff Flinn wrote:
>>> And a more descriptive, less jargon-ish name.
>> Why? Rich is proposing something that would iterate over the files
>> returned by the unix 'glob' function.
> As much as you might hate to admit it, you must recognize that the
> world
> does not revolve around UNIX (and before anyone claims otherwise, nor
> does
> the world revolve around Windows).
Of course revolves around the Mac :-) (whoops, better duck
and cover)

> To my knowledge, "glob" is not a standard computer term, nor a
> standard C++
> term, it is a standard UNIX term. Now, I could be wrong, but my
> understanding of the ISO standardization process is make everything
> platform-independent (and keep in mind that one of the original goals
> of
> Boost was to be included in the Standard). The *concept* of the "glob"
> is
> pretty much platform independent, but the term is not, so it should
> have (to
> paraphrase Jeff) a more descriptive, less platform-specific name.
Oh, I'll confess that I thought "glob()" was already part of the POSIX
but I'll admit I didn't look to be sure.

Anyway, the point is taken. To rephrase Russell's comment:
          " I don't care what it's called as long as I have its

Would a better name be "wildcard_iterator"?
perhaps "filename_iterator"? Can anyone offer other suggestions?

And while we're on the subject of platform/environment independence:
What should be the set of meta-characters? The initial implementation
supports csh/bash style "*", "?", "[ab-z]", "[^ab-z]", and "{a,b}".
the set be expanded? restricted?


Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at