Boost logo

Boost Users :

From: Mauricio Gomes (mg_at_[hidden])
Date: 2005-01-21 08:24:52

Hi Gennadiy, thank you for your tip ! I am still on the dark though.

I've run c++filt:

c++filt _ZTv0_n12_NSoD0Ev
virtual thunk to std::basic_ostream<char, std::char_traits<char>

Then I tried to run just this:
#include <iostream>

int main (int arc, char** argv)
        std::cout << "test";

... and it failed with the same error.
However, if I remove from the project the unit test framework files, it
runs fine.

I am using libstdc++.a. I don't understand what is happening.
Why when I add the unit test framework code it doesn't find the
standard library ~basic_ostream() anymore ?

It seems these last 5 years doing only Java got me really rusty with
C++ (I'd rather work with C++ but the market forced me to go to Java).

I really appreciate your help, thanks !

Best regards,
Mauricio Gomes
Pensar Digital
phone: 55-11-4121-6287
mobile: 55-11-8319-9610

On Jan 20, 2005, at 4:40 PM, Gennadiy Rozental wrote:

>> "Mauricio Gomes" <mg_at_[hidden]> wrote in message
>> Hello, I am trying to use boost unit test framework but I am getting
>> the
> following error message (it compiled okay but linking failed):
>> ----------------------------------------------------------------------
>> ----
> ------
>> [Session started at 2005-01-20 15:43:30 -0200.]
>> ZeroLink: unknown symbol '__ZTv0_n12_NSoD0Ev'
> Try to run through c++filt or something similar to demandle this symbol
> Gennadiy
> _______________________________________________
> Boost-users mailing list
> Boost-users_at_[hidden]

Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at