Boost logo

Boost Users :

From: Gennadiy Rozental (gennadiy.rozental_at_[hidden])
Date: 2005-01-21 11:21:43

> c++filt _ZTv0_n12_NSoD0Ev
> virtual thunk to std::basic_ostream<char, std::char_traits<char>

> Then I tried to run just this:
> #include <iostream>
> int main (int arc, char** argv)
> {
> std::cout << "test";
> }

> ... and it failed with the same error.
> However, if I remove from the project the unit test framework files, it
runs fine.


> I am using libstdc++.a. I don't understand what is happening.

So do I.

> Why when I add the unit test framework code it doesn't find the standard
library ~basic_ostream() anymore ?

Most probably looks like compiler bug

> It seems these last 5 years doing only Java got me really rusty with C++
(I'd rather work with C++ but the market forced me to go to Java).

I don't think 'last 5 years doing only Java' has anything to do with this.

Let's try couple more thigs:

1. Could you locate where this undefined symbol referenced from?
2. Could you build framework as a standalone library and link with it?


Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at