Boost logo

Boost Users :

From: Lonnie Princehouse (finite.automaton_at_[hidden])
Date: 2006-01-10 19:26:36

I tried the ebuild first, but it didn't work. As usual, it was my
fault (and not the ebuild's), but I was using the latest masked ebuild
(bgl-python says it needs boost 1.33.1), so in an attempt to eliminate
possible sources of error I unmerged the ebuild and installed boost
from scratch.

As is also usually the case, I figured things out about five minutes
after posting my message to the list --- so the problem is solved,
please don't anyone waste time answering the original post.

The problem seems to have been caused by using the wrong version of
boost-build; everything builds happily now that I've moved the
Python-BGL bindings directory into boost's directory so that it finds
the correct project-root and boost-build directories. I would still
like to know how to build a Boost.Python project from a directory
/outside/ of boost's hierarchy, but that's not really important. [I've
tried some guesses at the right stuff to put in boost-build.jam and
project-root.jam, but without success]

Incidentally, the original topic ("minor documentation update
request") was because I was going to say something about the
discrepancy between the Getting Started documentation (which links
only to the Boost.Build V1 installation info) and the Download page
which links to the latest (V2) Boost.Build. At the time I didn't
realize that the boost archive comes with in the tools/

... so complicated ... !!

On 1/10/06, Sebastian Redl <sebastian.redl_at_[hidden]> wrote:
> Lonnie Princehouse wrote:
> >(This is using Gentoo Linux, although boost/bjam/boost-build were
> >installed from scratch and not using the ebuilds)
> >
> >
> Why don't you use the ebuilds? They worked flawlessly for me.
> Sebastian Redl
> _______________________________________________
> Boost-users mailing list
> Boost-users_at_[hidden]

Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at