Boost logo

Boost Users :

From: Joaquín Mª López Muñoz (joaquin_at_[hidden])
Date: 2007-07-19 11:51:47


The docs explain that a parameter can be named:

  typedef parameter::parameters<
    required<tag::threading_policy>
    ...
> class_signature;
  ...
  class_<threading_policy<single_threaded>,...>;

or else be deduced:

  typedef parameter::parameters<
    required<
      deduced<tag::threading_policy>,
      is_base_and_derived<threading_policy_marker,_>
>
    ...
> class_signature;
  ...
  class multithreaded: threading_policy_marker{...};
  class_<multithreaded,...>;

Now, is it possible to combine these two options into one, so that the
the two syntaxes

  class_<threading_policy<single_threaded>,...>;
  class_<multithreaded,...>;

are accepted? If so, how?

Thank you,

Joaquín M López Muñoz
Telefónica, Investigación y Desarrollo


Boost-users list run by williamkempf at hotmail.com, kalb at libertysoft.com, bjorn.karlsson at readsoft.com, gregod at cs.rpi.edu, wekempf at cox.net