Boost logo

Boost Users :

From: David Abrahams (dave_at_[hidden])
Date: 2007-07-19 15:02:43


on Thu Jul 19 2007, Joaquín Mª López Muñoz <joaquin-AT-tid.es> wrote:

> The docs explain that a parameter can be named:
>
> typedef parameter::parameters<
> required<tag::threading_policy>
> ...
> > class_signature;
> ...
> class_<threading_policy<single_threaded>,...>;
>
> or else be deduced:
>
> typedef parameter::parameters<
> required<
> deduced<tag::threading_policy>,
> is_base_and_derived<threading_policy_marker,_>
> >
> ...
> > class_signature;
> ...
> class multithreaded: threading_policy_marker{...};
> class_<multithreaded,...>;
>
> Now, is it possible to combine these two options into one, so that the
> the two syntaxes
>
> class_<threading_policy<single_threaded>,...>;
> class_<multithreaded,...>;
>
> are accepted? If so, how?

Just used deduced<tag::threading_policy>; deduced parameters can be
deduced from argument types or from the names attached to named
arguments.

-- 
Dave Abrahams
Boost Consulting
http://www.boost-consulting.com
The Astoria Seminar ==> http://www.astoriaseminar.com

Boost-users list run by williamkempf at hotmail.com, kalb at libertysoft.com, bjorn.karlsson at readsoft.com, gregod at cs.rpi.edu, wekempf at cox.net