Boost logo

Boost Users :

From: Ion Gaztañaga (igaztanaga_at_[hidden])
Date: 2007-12-08 19:42:52


gchen wrote:
> What is the difference of this library from hash_map in some STL
> extention libraries?
> Is it just a new name for hash_map/hash_set?

Hash containers were not standardized so there are different
implementations with different guarantees and features (some used
incremental hashing or bidirectional iterators) and C++ unordered
containers have been standardized to support a broad range of
implementations adding new features, like bucket iterators.

You shouldn't use hash_map and other similar containers if you want to
write portable code just because they are not standard. Unordered aims
to be the Boost implementation of standard C++ hash containers.

For more information about the rationale and the evolution of unordered
containers design see Matthew Austern's proposal:

A Proposal to Add Hash Tables to the Standard Library (revision 4)

http://www.open-std.org/jtc1/sc22/wg21/docs/papers/2003/n1456.html

Regards,

Ion


Boost-users list run by williamkempf at hotmail.com, kalb at libertysoft.com, bjorn.karlsson at readsoft.com, gregod at cs.rpi.edu, wekempf at cox.net