Boost logo

Boost Users :

From: Scott McMurray (me22.ca+boost_at_[hidden])
Date: 2008-05-05 09:34:34


On Mon, May 5, 2008 at 8:19 AM, Kevin Martin <kev82_at_[hidden]> wrote:
> I think I have done it with the expression:
>
> _1 && bind(&dynamic_bitset<>::test, bind(&Object::GetBitset, *_1), n)
>
> It seems to work, so I'm guessing it is correct. Is there a better way
> to write it though, because it seems rather difficult to read.
>

You might prefer

    _1->*&Object::GetBitset

to the inner bind, but I'm not convinced it can get much better.


Boost-users list run by williamkempf at hotmail.com, kalb at libertysoft.com, bjorn.karlsson at readsoft.com, gregod at cs.rpi.edu, wekempf at cox.net