Boost logo

Boost Users :

Subject: [Boost-users] Installing boost 1.38 in UBUNTU 8.10
From: jan acosta (acosta.janp_at_[hidden])
Date: 2009-03-03 01:19:20

Hey guys,

I am having trouble linking my boost libraries to a program I am trying to
install. I need to install boost versions above 1.37 and ubuntu doesn't
have packages yet for anything above 1.35.

I am trying to install this program:

I followed the steps in his wiki but I always get this error message:

g++ -pthread -shared -Wl,-Bsymbolic-functions
-L/home/supacreative/pool/include/lib -L/usr/local/cuda/lib
-lboost_python-gcc41-mt -lcuda -o
/usr/bin/ld: cannot find -lboost_python-gcc41-mt
collect2: ld returned 1 exit status
error: command 'g++' failed with exit status 1

I can't get past this error. I've tried using the export command using:
export LD_LIBRARY_PATH=/home/(my username)/pool/lib:$LD_LIBRARY_PATH

and I still get the same error message.

I even added the library folder into my and ran ldconfig to
restart ld, but I still get the same error.

Please help.


Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at