Boost logo

Boost Users :

Subject: Re: [Boost-users] 1.41.0 fails to compile on Windows 7 with VisualStudion 2008 tools
From: Mike Jackson (mike.jackson_at_[hidden])
Date: 2009-12-05 14:53:26

Going from some older notes I had I believe I used the following from
a 32 bit Visual Studio command prompt.

bjam.exe toolset=msvc-9.0 --with-test --with-filesystem
--with-program_options --with-date_time --with-thread
--prefix=C:\Developer\VS9\boost_1_41 --layout=tagged
variant=release,debug threading=multi link=static runtime-link=shared

I guess I should have tried the default values to compile but this has
worked since 1.36 on Windows XP and Windows 7 in both 32 and 64 bit

Mike Jackson mike.jackson_at_[hidden]

On Sat, Dec 5, 2009 at 12:05 PM, Zachary Turner <divisortheory_at_[hidden]> wrote:
> On Sat, Dec 5, 2009 at 8:12 AM, Mike Jackson <mike.jackson_at_[hidden]>
> wrote:
>> I believe something down in the unit test framework was being
>> compiled. I am away from my work machine so I can not be more
>> specific. I don't think I did anything out of the ordinary when trying
>> to compile Boost. I downloaded the tar ball from, used bjam
>> to configure and build. Then I got the errors. Although I do find it
>> odd that this was not caught during the release preparations.
>>  So I am thinking maybe a Windows 7 x64, VS2008 specific bug?
> I compiled on Windows 7, x64, Visual Studio 2008 just yesterday and it
> worked fine.  What command line did you use?
> _______________________________________________
> Boost-users mailing list
> Boost-users_at_[hidden]

Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at