Boost logo

Boost Users :

Subject: Re: [Boost-users] 1.41.0 fails to compile on Windows 7 with VisualStudion 2008 tools
From: Zachary Turner (divisortheory_at_[hidden])
Date: 2009-12-05 14:59:58

On Sat, Dec 5, 2009 at 1:53 PM, Mike Jackson <mike.jackson_at_[hidden]>wrote:

> Going from some older notes I had I believe I used the following from
> a 32 bit Visual Studio command prompt.
> bjam.exe toolset=msvc-9.0 --with-test --with-filesystem
> --with-program_options --with-date_time --with-thread
> --prefix=C:\Developer\VS9\boost_1_41 --layout=tagged
> variant=release,debug threading=multi link=static runtime-link=shared
> install
> I guess I should have tried the default values to compile but this has
> worked since 1.36 on Windows XP and Windows 7 in both 32 and 64 bit
> flavors.

I'll admit I'm actually not familiar with any of these options. What do the
with* options do? All of those libraries are built by default anyway. For
the record it doesn't matter what command prompt you use, even if it's not a
visual studio command prompt at all. In any case, I used:

bjam toolset=msvc-9.0 address-model=64 --build-type=complete stage

If you just want to get a build out, you can probably try this until someone
figures out the build issue with the specific set of options you were using.

Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at