Boost logo

Boost Users :

Subject: Re: [Boost-users] Forthcoming Boost.Fiber review
From: Nathan Ridge (zeratul976_at_[hidden])
Date: 2013-12-19 00:43:43

> One very minor quibble (which I'll share now because I'm not sure if > I'll be around during the formal review period): I don't like how the > library is called "Fiber", in subdir "fiber", but in namespace "fibers". > I do prefer namespace "fibers" (since boost::fiber::fiber would be > annoying), but I think the library and dir should also be called > "fibers" too. There is precedent for this pattern in Boost:   Boost.Coroutine places its names in boost::coroutines   Boost.Tuple places its names in boost::tuples There are probably others that don't come to mind at the moment. Regards, Nate

Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at