Boost logo

Boost Users :

From: Maarten Verhage (m_r_verhage_at_[hidden])
Date: 2019-07-29 15:27:06

Dear Boost.Build expert,

I do have Boost 1.69 and was able to build from the sources with Mingw-w64
gcc 8.1 on Windows 7. That was for boost itself, but now I need to build the
tests for the Boost library Spirit (the parser). I cannot get this to work.

My Boost.Build version is 2018.02-git.

According to Boost.Build paragraph 3.3 Configuration, the option
"b2 --debug-configuration" gives info how my is configured.

In the folder <boost-build>\example\hello the output of
"b2 --debug-configuration" looks fine. But when I run from the folder
<boost-spirit-develop>\test "b2 --debug-configuration" the output contains:
error: Could not find parent for project at '.'.
So in the folder <boost-spirit-develop>\test I rename Jamfile to
Jamroot.jam. Now with "b2 --debug-configuration" I get: output.txt
(attachtment of this email)

Also when I try to build the tests it I gets the same error messages
strarting from:
config.jam: No such file or directory

How do I solve this?

Best regards,
Maarten Verhage

Boost-users list run by williamkempf at, kalb at, bjorn.karlsson at, gregod at, wekempf at