Boost logo

Geometry :

Subject: [ggl] plan
From: Mateusz Loskot (mateusz)
Date: 2009-04-22 04:27:56


Barend Gehrels wrote:
> Hi,
>
> To summarize, the plan is on April 25:
>
> 1) reflect the folder structure to the one in the boost sandbox, so:
> - boost/ggl with headers
> - libs/ggl with tests, examples, documentation

+1

> 2) change "geometry" to "ggl" in #include statements, so e.g. #include
> <ggl/core/ring_type.hpp>

+1

> 3) change "geometry" to "ggl" in namespaces

+1

> 4) not indent namespaces

+1

I've already fixed it in io/wkt (r591)

> 5) replace tabs with 4 spaces

+1

> 6) in the test folder create the structure as in the headerfiles, so
> .../algorithms, ../core, ../strategies, etc

+1

> 7) rename fromwkt.hpp to read_wkt.hpp and aswkt.hpp to write_wkt.hpp,
> and then also streamwkt.hpp to stream_wkt.hpp

+1

> 8) move the stuff in multi which is not yet structured to the right
> subfolders

+1

> All these cosmetic changes will be atomic and I will do most of them
> "automatic", I will update the MS project files as well.

OK. thanks!
I can update Jamfiles.

By the way, I've taken the liberty to apply one more cosmetic change:
I replaced the TOK aliase with tokenizer name in io/wkt:

typedef boost::tokenizer<boost::char_separator<char> > TOK;

reads now:

typedef boost::tokenizer<boost::char_separator<char> > tokenizer;

If you'd agree, I'd suggest to use upper-case for template parameters
only, otherwise it's hard to decipher what is what when reading through
code and requires to go back up to function/type prototype to find out.

Best regards,

-- 
Mateusz Loskot, http://mateusz.loskot.net

Geometry list run by mateusz at loskot.net