Subject: [ggl] plan
From: Mateusz Loskot (mateusz)
Date: 2009-04-24 13:00:07
Barend Gehrels wrote:
>> 2) change "geometry" to "ggl" in #include statements, so e.g. #include
> Done (also renamed include guards from _GEOMETRY_ to GGL_, this was
> automatic, not yet inserted subfolders)
I'm wondering if we shouldn't including using path relative to boost,
for example in cooridnate_type.hpp:
>> 7) rename fromwkt.hpp to read_wkt.hpp and aswkt.hpp to write_wkt.hpp,
>> and then also streamwkt.hpp to stream_wkt.hpp
>> 8) move the stuff in multi which is not yet structured to the right
> Not yet done, will be done soon.
> Everything is currently committed again. Note that there was one error
> during renaming/copying, resulting in some svn-errors (such as copyflag
> in properties, etc). Therefore the svn-history in multi* is lost, sorry
> about that. I was able to keep the history in strategies etc (which is
> much more interesting anyway).
I'm going to update tests accordingly.
Big thanks for the transition job!
-- Mateusz Loskot, http://mateusz.loskot.net Charter Member of OSGeo, http://osgeo.org
Geometry list run by mateusz at loskot.net