Boost logo

Geometry :

Subject: [ggl] namespace renaming
From: Mateusz Loskot (mateusz)
Date: 2009-12-03 07:41:14

Bruno Lalande wrote:
> Hi,
>> So I propose namespace shape for the neutrally-named collection of shapes.
>> We then get:
>> boost::geometry::shape::point<...> // as we have it now in boost::geometry
>> boost::geometry::shape::polygon<...> // as we have it now in
> It's better than "geometry" indeed. However maybe an even better name
> would be "model", since those geometries model the concepts GGL
> defines. It would state more clearly that those shapes are not mere
> shapes but are also examples of models for our concepts.

I like shape. I like model. I've been also thinking about primitive
after "geometry primitive", as another possibility.

Best regards,

Mateusz Loskot,

Geometry list run by mateusz at