Subject: [ggl] reversible_range and closeable_range
From: Barend Gehrels (barend.gehrels)
Date: 2010-05-04 14:05:04
A few days ago I posted about the "reversible_view". Now also a
"closeable_view" has been added. Area can then be calculated from either
clockwise or counterclockwise polygons, either closed or open (closed
means: first point == last point).
So the a reversible view can be nested within a closeable view. Both
have Boost.Ranges as input, and act as Boost.Ranges.
So I propose to rename them to "_range". There is not yet a
reversible_range within boost, though one of the test files is called
So proposal is: util/reversible_view.hpp -> ranges/reversible_range.hpp
and same for closeable
They are brand new so no compatibility problems here.
Geometry list run by mateusz at loskot.net