Subject: [ggl] reversible_range and closeable_range
From: Bruno Lalande (bruno.lalande)
Date: 2010-05-07 08:55:46
Nice addition, thanks :-) I had thought about such thing many times,
it's really useful.
I wouldn't rename this into range. A view is always a range, so this
particular case is not an exception in this regard. A view is
something that behaves like a range but doesn't really contain the
elements it iterates other. It's rather a proxy to those elements
(which come from a "real" range, that is their real owner). If a
reversible_range appears in Boost, I suspect it would rather be called
reversed_view (or simply reversed, as Boost.Range naming convention
seems to be to not even mention "view" at all).
Geometry list run by mateusz at loskot.net