Subject: [ggl] namespace renaming (model)
From: Barend Gehrels (barend.gehrels)
Date: 2010-11-28 10:33:29
On 3-12-2009 13:32, Bruno Lalande wrote:
>> So I propose namespace shape for the neutrally-named collection of shapes.
>> We then get:
>> boost::geometry::shape::point<...> // as we have it now in boost::geometry
>> boost::geometry::shape::polygon<...> // as we have it now in
> It's better than "geometry" indeed. However maybe an even better name
> would be "model", since those geometries model the concepts GGL
> defines. It would state more clearly that those shapes are not mere
> shapes but are also examples of models for our concepts.
Much later, this has been done.
For example: boost::geometry::point_xy is now
So please update your sources, or (recommended) a SVN tag has been
created just before updating, so the most recent version before this
change is here:
The proposal contained more namespace renamals, I assume that this is
still agreed by everyone.
1) boost::geometry::d3::point (for current point_3d) still to be done,
but this should (I think) still be in namespace model
2) algorithm::distance instead of distance
3) and also "ogc::distance". But it might be that "st::distance" is seen
as a more appropriate name, because all spatial databases use it like
that (ST_Distance, STDistance(), etc).
4) singular names, no plural names (also for folders?)
-------------- next part --------------
An HTML attachment was scrubbed...
Geometry list run by mateusz at loskot.net