Boost logo

Geometry :

Subject: [ggl] combine
From: Bruno Lalande (bruno.lalande)
Date: 2011-03-29 09:49:43


Btw, to be completly honest, intersection_inserter should be the name of an
>> object, not function. Function's name should be the verb:
> I agree, it is confusing.
> So everybody agrees on this last moment renaming "inserter" to "insert" ?

I had forgotten to reply at that moment. I'm not sure to agree with this. I
don't see any reason to name it with a verb, as conceptually it's neither an
object or a function, it's a functor. The underlying type could be an object
or an actual function, it wouldn't change its name. BTW we could very well
migrate from function to class in a future release for some reason, that
wouldn't change how we name this functor conceptually (for compatibility
reasons, to start with).

> And "make_" is also not OK with this respect. "The types for the pair class
> are implicitly deduced from the arguments passed to make_pair."
> While that type with make_centroid (and others), on the contrary is
> required.
> 1) centroid(polygon, p)
> 2) p = <PointType>make_centroid(polygon)
> It might be renamed to return_centroid, so
> 2) p = return_centroid<PointType>(polygon).

Yep that might be a good idea.

-------------- next part --------------
An HTML attachment was scrubbed...

Geometry list run by mateusz at