Boost logo

Geometry :

Subject: [ggl] spacial index
From: Adam Wulkiewicz (adam.wulkiewicz)
Date: 2011-03-29 09:02:40


W dniu 2011-03-29 11:08, Bruno Lalande napisal(a):
> Hi,
>
>
> The thing is, it stores values in leafs. Classic approach will be to
> use Value of type std::pair<Box, Id> but it may be anything. IMO
> it's better to have Value argument on the parameters list:
> rtree<Value>. So the user knows that there is a hierarchy of nodes
> and at the bottom values are stored, and values will be retrieved by
> some query. And the translator just translates Value to Indexable.
> Btw now
> the Translator parameter parameter can be of type
> index::default_parameter and the default translator type is build
> inside the tree.
>
>
> OK I think I confused Value and Indexable in my previous email. You're
> right, Value is what we really store (the ID). Let's stick to that, and
> just remove the Box parameter and retrieve all related things either
> using Value or Translator.

To be precise. In the classic design of an rtree there are pairs of MBR
and ID stored in leafs, something like std::pair<Box, int>. In our rtree
Values are stored. User may define Value as a pair of Box and int and
have the classic one. But he may also define Value as a Box, Point or
any UserClass and this Value will be stored.

Is Value name confusing in some way? I named it so because it refer to
the std containers value_type (type which is stored). It is not an ID.
It could be named Indexable as well but then we should find good name
for an object retreived by the translator.

Regards,
Adam


Geometry list run by mateusz at loskot.net