Subject: [ggl] boost geometry rtree
From: Simonson, Lucanus J (lucanus.j.simonson)
Date: 2011-07-18 16:28:34
Adam Wulkiewicz wrote:
> Adam Wulkiewicz wrote:
>>> OK, I will look/ask for this in more detail. If anyone on this list
>>> know the very right term, it is welcome. So the question is:
>>> "content" means: length-in-1-D, area-in-2-D, volume-in-3-D
>>> "XXX" means: perimeter-in-2-D, area-in-3-D
>>> where "XXX" might be margin. The term "content" is quite difficult
>>> to Google, by the way.
>> Other possibility is to use straightforward hypervolume and
>> hypersurface. They're both at MathWorld's pages I've mentioned and
>> to be honest I've found pages googling these terms. Other ideas?
> Since mathematical names like hypervolume, hypersurface and hyperarea
> may be confusing and there isn't probably any other name describing it
> we may just make something up. Ideas:
> - some word corresponding to 'content' - wrapping, packing, packaging
> - border, border_zone, XXX_zone
> - mantle (I like this, and then content may be replaced by core but
> this is a lot more confusing)
> - coat, jacket
> Btw I like the 'margin' term, in the case of 2d it associates to the
> part of the area around the object, not the perimeter but it fits more
> or less.
My preference would be to use area and perimeter for 2D; volume and surface_area for 3D and hypervolume and hypersurface for N-D. I believe this issue was discussed in the boost list quite a while ago. We can easily wrap hypersurface and hypervolume with functions that have more intuitive names for the object type passed in and check that it conforms to the right number of dimensions at compile time. Area() requires 2D geometry, volume requires 3D and hypervolume works on anything.
Geometry list run by mateusz at loskot.net