Subject: Re: [geometry] bounding object calculation
From: Bruno Lalande (bruno.lalande_at_[hidden])
Date: 2013-08-27 09:24:47
Sorry to chime in so late... would "minimum_bounding" be an option? I'd
like to keep "minimum" in the name, as opposed to "any" shape that can
encapsulate the geometry. And I like to keep "bounding" as well because
it's a well known term and it results in expression which are almost the
literal English sentence of what you want
(return_minimum_bounding<box>(...) => "return minimum bounding box"). The
word "geometry" can be omitted IMO, sounds a bit redundant.
I hear Barend's point about OGC, but even though the majority of
Boost.Geometry is currently GIS/OGC oriented, it's supposed to be
potentially more general, so I'd like to make sure we are not excessively
tying ourselves to OGC terminology...
Geometry list run by mateusz at loskot.net