Boost logo

Proto :

Subject: Re: [proto] Visitor Design Pattern
From: Thomas Heller (thom.heller_at_[hidden])
Date: 2010-10-24 05:10:17

On Sun, Oct 24, 2010 at 9:59 AM, Joel de Guzman
<joel_at_[hidden]> wrote:
> On 10/24/2010 1:16 PM, Eric Niebler wrote:
>> Now, what to call the traveral/algorithm/action/on thingy. None of those
>> feel right. Maybe if I describe in words what it does, someone can come
>> up with a good name. Given a Proto grammar that has been built with
>> named rules, and a set of actions that can be indexed with those rules,
>> it creates a Proto algorithm. The traversal is fixed, the actions can
>> float. It's called<insert good name here>.
> Actor
>  std::cout << actor<char_terminal, my_actions>()(a)  << "\n"; // printing
> char
> :-)

Cool, then we'd need some new name for phoenix, hmn?
I like:

Proto list run by eric at