From: Anthony Williams (anthony_at_[hidden])
Date: 2006-04-11 05:01:51
Roland Schwarz <roland.schwarz_at_[hidden]> writes:
> I have just uploaded my first attempt to reorganize the threading code
> into platform dependent sections, to the vault.
Good work. I think it should be renamed back to "thread" before putting in CVS
--- why threadpp, anyway?
> It is also possible to have some shared code, although I currently split
Where the code is truly shared (e.g. timeconv.inl), it would be better to have
only one version.
> The users later can decide at link time of his application which variant
> to use, i.e. pthread or native.
To decide that late would require that there was no platform-specific code in
the headers, which I don't think is really viable, so they will have to decide
when they compile their app, by setting appropriate defines. Isn't that what
your dispatch code does anyway?
-- Anthony Williams Software Developer Just Software Solutions Ltd http://www.justsoftwaresolutions.co.uk