From: Roland Schwarz (roland.schwarz_at_[hidden])
Date: 2006-04-11 06:55:37
Anthony Williams wrote:
> I think it should be renamed back to "thread" before putting in CVS
> --- why threadpp, anyway?
A joke, thread++ ;-)
I just needed a name to test everything within the same tree. Btw. since
not everything is in the rewrite yet,
is it ok to purge the parts not yet moved into the new dir layout? The
"old" parts are still available from the cvs
attic during this time.
> Where the code is truly shared (e.g. timeconv.inl), it would be better to have
> only one version.
Possibly exceptions and config.hpp also should be shared...
> To decide that late would require that there was no platform-specific code in
> the headers, which I don't think is really viable, so they will have to decide
> when they compile their app, by setting appropriate defines.
Absolutely true. This is what I really meant. Link time is too late (but
would be a nice to have).
> Isn't that what
> your dispatch code does anyway?
Yes. By specifying BOOST_THREAD_POSIX the pthread variant will get
I will try to check this into the repository today evening (around
Please be prepared that building on the thread_rewrite branch will be
broken afterwards, until everything has been
moved. I know this is not an ideal solution, but this way I will no
longer hold off the rewrite.
I would kindly ask you then with helping getting everything into shape