Boost logo

Ublas :

Subject: Re: [ublas] Test results for getri and getrf
From: Rutger ter Borg (rutger_at_[hidden])
Date: 2009-03-09 02:56:40

Thomas Klimpel wrote:
> No, std::ptrdiff_t is a very good type in this case. The type integer_t is
> just the type that the user told FORTRAN to use for integer. So umfpack
> and other a c-libraries would not be happy when integer_t occurs in their
> interface.

I see. To make the code more readable and flexible (i.e., defined in one
place, by us), would it an idea to typedef it to a more natural name? I.e.,
something like size_type?