Boost logo

Ublas :

Subject: Re: [ublas] Test results for getri and getrf
From: Thomas Klimpel (Thomas.Klimpel_at_[hidden])
Date: 2009-03-09 06:29:16

Rutger ter Borg wrote:
> I see. To make the code more readable and flexible (i.e., defined in one
> place, by us), would it an idea to typedef it to a more natural name? I.e.,
> something like size_type?

Perhaps, but we would need a good name first. size_type is not a good name, because it is too closely associated with std::size_t, which is an unsigned type. Multi_Array uses "typedef std::ptrdiff_t index;" and uBlas seems to use "difference_type". Both don't really sound significantly more natural than std::ptrdiff_t to me. However, their purpose is probably not to sound natural, but to provide a typedef that can be changed if need arises. I think "integer_type" or "int_type" would sound sufficiently natural to me. However, note that Multi_Array and uBlas burry such typedefs deep into their namespaces, such that no conflicts with other typedefs occur. So the actual type would be boost::numeric::bindings::int_type.