Boost logo

Ublas :

Subject: Re: [ublas] todo list
From: David Bellot (david.bellot_at_[hidden])
Date: 2010-07-24 08:14:57


the element-wise operations are most of the time syntactic sugar but it
makes a code easier to read.
For example in matlab vector + scalar is equivalent to vector +
scalar_vector(scalar).
And mathematically, this is what we must think. However, it's easier to
write vector + scalar.

I put things like sum(...) and others functions in the section on
algorithms. Indeed, we need more of them.
So we have vector/matrix reductions which have a correct mathematical
meaning. We can make things even more beautiful than matlab. Instead of
passing a parameter of 1 or 2 to specify row or column wise (for matrix), we
can tag the function. Let's see what's the nicest.
And we have "non-correct" mathematical functions which are convenient to
write.

Regarding your second question, someone mentioned the fact we could have
both:
- basic implementations of those algorithms (maybe not all of them but the
most important),
- bindinds.

Because most of the people expect to have this type of algorithm. We will
explain in the documentation that for those who wants to have faster,
better, shinier implementations, they have to use the bindings. We will not
look at providing the best implementations ever, but fairly good one. Yes,
it's redondant but it will please a lot of user and make ublas a more
complete library. And we will make a lot of noise about this when it's ready
! :-D

Cheers,
David

# SVD, Cholesky, LU, QR, Shur
> Do you think this should be written from scratch or maybe using
> existent solvers like the one provided by LAPACK (possibly using the
> boost::numeric::bindings lib)?
>
> Thank you very much
>
> Cheers,
>
> -- Marco
> _______________________________________________
> ublas mailing list
> ublas_at_[hidden]
> http://lists.boost.org/mailman/listinfo.cgi/ublas
> Sent to: david.bellot_at_[hidden]
>

-- 
David Bellot, PhD
david.bellot_at_[hidden]
http://david.bellot.free.fr